summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aac2318bc454..c78fdd5fa791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,37 @@
pkgname=novel-cli
pkgver=0.3.1
-pkgrel=0
-pkgdesc='tool for downloading novels from the web, manipulating text, and generating EPUB '
+pkgrel=1
+pkgdesc='tool for downloading novels from the web, manipulating text, and generating EPUBs'
arch=(x86_64)
url='https://github.com/novel-rs/cli'
license=(Apache MIT)
depends=(gcc-libs)
-makedepends=(cargo
+makedepends=(rustup
clang
- cmake)
+ cmake
+ sqlite)
_archive="cli-$pkgver"
source=("$url/archive/$pkgver/$_archive.tar.gz")
sha256sums=('01dca1b084488b455d8355bbfeea783d68b8a795d7166c82f0eef70daaa5e7e7')
prepare() {
cd "$_archive"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ rustup toolchain install stable
+ cargo +stable fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
cd "$_archive"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cargo build --frozen --release --all-features
+ cargo +stable build --frozen --release --all-features
}
check() {
cd "$_archive"
export RUSTUP_TOOLCHAIN=stable
- cargo test --frozen --all-features
+ cargo +stable test --frozen --all-features
}
package() {