summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b181d6862f6..a1ae47663d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=nullshell-git
-pkgver=0.0.6.r0.g967686e
+pkgver=0.0.7.r1.g09a906b
pkgrel=1
pkgdesc="do nothing but print keep alive characters, can be used for login shell - git checkout"
arch=('i686' 'x86_64')
-makedepends=('markdown' 'git')
+makedepends=('git' 'discount')
url="https://github.com/eworm-de/nullshell"
conflicts=('nullshell')
license=('GPL')
install=nullshell.install
-source=('git://github.com/eworm-de/nullshell.git')
+source=('git+https://github.com/eworm-de/nullshell.git')
sha256sums=('SKIP')
pkgver() {
cd nullshell/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git rev-parse --short HEAD)"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git rev-parse --short HEAD)"
fi
}