summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..435ebab1ecde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=numactl-git
+pkgver=2.0.11.r14.gea3a706
+pkgrel=1
+pkgdesc="Simple NUMA policy support"
+arch=('i686' 'x86_64')
+url="http://oss.sgi.com/projects/libnuma/"
+license=('GPL' 'LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=('numactl')
+conflicts=('numactl')
+options=('staticlibs')
+source=("git+https://github.com/numactl/numactl.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "numactl"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "numactl"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "numactl"
+
+ make check
+}
+
+package() {
+ cd "numactl"
+
+ make DESTDIR="$pkgdir" install
+
+ # move_pages(2) is provided by man-pages and is more up-to-date there anyway
+ rm -r "$pkgdir/usr/share/man/man2"
+}