summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df35fd750914..294d4b39a04a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgname='nuxhash-git'
pkgver=v1.0.0b2.r33.g33e9a09
-pkgrel=1
+pkgrel=2
pkgdesc="A NiceHash cryptocurrency mining client for Linux."
arch=('x86_64' 'i686')
url="https://github.com/YoRyan/nuxhash"
license=('GPL3')
depends=('python' 'curl' 'nvidia' 'opencl-nvidia')
-makedepends=('python-pip')
optdepends=('python-wxpython: GUI support')
-source=("git+https://github.com/YoRyan/nuxhash.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/YoRyan/nuxhash.git"
+ "nuxhash-gui.desktop")
+sha256sums=('SKIP'
+ '779c28c990c97b6c6fb2b2ad1cf84ff99dcdf5c1b72f034750994fdc8a645055')
pkgver() {
cd nuxhash
@@ -19,5 +20,8 @@ pkgver() {
}
package() {
- pip install ./nuxhash --root "$pkgdir" --no-warn-script-location
+ cd nuxhash
+ python3 setup.py install --root "${pkgdir}/"
+ install -Dm644 nuxhash/gui/icons/nuxhash.svg "$pkgdir/usr/share/pixmaps/nuxhash.svg"
+ install -Dm644 ../nuxhash-gui.desktop "$pkgdir/usr/share/applications/nuxhash-gui.desktop"
}