summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad5933dd83a6..eacd90a7ef02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Thomas Baechler <thomas@archlinux.org>
pkgname=nvidia-340xx-ck
-pkgver=340.93
+pkgver=340.96
_extramodules=extramodules-4.3-ck
-pkgrel=4
+pkgrel=1
pkgdesc="NVIDIA drivers for linux-ck, 340xx legacy branch."
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
@@ -16,14 +16,10 @@ conflicts=('nvidia-ck' 'nvidia-304xx-ck' 'nvidia-275xx-ck' 'nvidia-319-ck' 'nvid
license=('custom')
install=nvidia-340xx-ck.install
options=(!strip)
-source=("nv-drm.patch"
-"nvidia-4.3-build.patch")
source_i686+=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha256sums=('9515310b017ad4134f50e92b39cb437e3d18605d26aead1dda02599d41e6ee26'
- '0e11d4d73556e39fffce5b8c14674ede0064cabee058d9fb8f8bd7c3035fca5d')
-sha256sums_i686=('4a81c158302c595e1e72b5a1812eb3c67c8cf584ca74b1bc24163dad5289d612')
-sha256sums_x86_64=('8fb230a7579a15c778ab7c2f160830682919729235beb8ea2b84326528c54843')
+sha256sums_i686=('c40e2778cd1ab036a76e1896fe2f77c4aa7baa215dbbdb11a2f4c5f05e1a478e')
+sha256sums_x86_64=('280f9db2aea52cab42e141f0393604c7a6d43e7f65d3e60c2319c2674ecc14c4')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -31,8 +27,6 @@ sha256sums_x86_64=('8fb230a7579a15c778ab7c2f160830682919729235beb8ea2b84326528c5
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
- patch -Np0 -i "$srcdir/nv-drm.patch"
- patch -Np1 -i "$srcdir/nvidia-4.3-build.patch"
}
build() {