summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e845f56e74a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kevin Del Castillo R. <lans9831@gmail.com>
+
+pkgname=nvman
+pkgver=1.0
+pkgrel=1
+pkgdesc="nvman - NVIDIA Manager for Optimus"
+arch=('any')
+license=('GPL')
+depends=('bumblebee' 'primus' 'optimus-manager')
+optdepends=()
+conflicts=()
+options=()
+install=$pkgname.install
+source=("https://github.com/lans98/$pkgname/archive/$pkgver.tar.gz")
+md5sums=(ced7000e6610a98c6996debdab4a9dd8)
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/lib/systemd/system/"
+ mkdir -p "$pkgdir/etc/nvman/"
+
+ install $pkgname "$pkgdir/usr/bin/"
+ cp "$pkgname.service" "$pkgdir/usr/lib/systemd/system/"
+ cp config "$pkgdir/etc/nvman/"
+}