summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 733d1919f709..c345125e8aa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,35 +5,26 @@
# Contributor: Felix Golatofski <contact@xdfr.de>
pkgname=nyxt
-pkgver=3
+pkgver=2.2.4
pkgrel=1
pkgdesc="A keyboard-oriented, infinitely extensible web browser designed for power users"
arch=('x86_64')
url="https://github.com/atlas-engineer/nyxt"
license=('custom:BSD')
-conflicts=('nyxt-browser')
-provides=('nyxt-browser' 'next-browser')
-source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver}")
-#source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver//./-}"
-# "Makefile.2.pre.release.7.patch"
-# "renderer-gi-gtk.lisp.issue.1374.patch")
-sha256sums=('SKIP')
+depends=('enchant' 'glib-networking' 'gobject-introspection-runtime' 'gsettings-desktop-schemas' 'libfixposix' 'webkit2gtk')
# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
makedepends=('cl-asdf' 'git' 'gobject-introspection-runtime' 'sbcl')
-depends=('enchant' 'glib-networking' 'gobject-introspection-runtime' 'gsettings-desktop-schemas' 'libfixposix' 'webkit2gtk')
optdepends=('gstreamer: for HTML5 audio/video'
'gst-plugins-base: for HTML5 audio/video'
'gst-plugins-good: for HTML5 audio/video'
'gst-plugins-bad: for HTML5 audio/video'
'gst-plugins-ugly: for HTML5 audio/video')
+provides=('nyxt-browser' 'next-browser')
+conflicts=('nyxt-browser')
# Binary will not run otherwise.
options=('!strip' '!makeflags')
-
-#prepare() {
-# cd "${srcdir}"/"${pkgname}"/
-# patch -p1 -i ../Makefile.2.pre.release.7.patch
-# patch -p1 -i ../renderer-gi-gtk.lisp.issue.1374.patch
-#}
+source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver}")
+b2sums=('SKIP')
build() {
cd "${srcdir}"/"${pkgname}"/