summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd9a561cb5aa..856b6dda2354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,37 @@
-# $Id: PKGBUILD 277856 2018-01-03 07:03:59Z foutrelis $
-# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Maintainer: xiretza <xiretza+aur@gmail.com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
pkgname=obexftp
-pkgver=0.24
-pkgrel=12
+pkgver=0.24.2
+pkgrel=1
pkgdesc="A tool for transfer files to/from any OBEX enabled device"
arch=('x86_64')
url="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
license=('GPL')
-depends=('openobex')
-makedepends=('cmake' 'asciidoc' 'xmlto' 'fuse2' 'swig' 'ruby' 'tk')
+provides=('obexfs')
+replaces=('obexfs')
+depends=('openobex' 'expat' 'fuse2')
+makedepends=('cmake' 'asciidoc' 'xmlto' 'swig' 'ruby' 'tk')
optdepends=('ruby: ruby bindings'
'tk: TCL/Tk bindings')
options=('!makeflags' '!docs')
-source=("http://downloads.sourceforge.net/openobex/${pkgname}-${pkgver}-Source.tar.gz")
-md5sums=('31a50dbbd09c63cbb5399772aaff7936')
+source=("http://downloads.sourceforge.net/openobex/${pkgname}-${pkgver}-Source.tar.gz"
+ "explicitly-link-libbfb-and-libmulticobex.patch")
+sha256sums=('d40fb48e0a0eea997b3e582774b29f793919a625d54b87182e31a3f3d1c989a3'
+ 'b2bdc9c9ad1894864d77531549be6f921f8d04344c64185ca053cc677c609a50')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}-Source"
+ patch -p1 < "${srcdir}/explicitly-link-libbfb-and-libmulticobex.patch"
+}
build() {
cd "${srcdir}/"
mkdir build
cd build
- cmake ../${pkgname}-${pkgver}-Source \
+ cmake "../${pkgname}-${pkgver}-Source" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \