summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f515baf91466..ce8df7b0d7f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
-_pkgname=obozrenie
-pkgname=$_pkgname-git
-pkgver=r224.3f2815b
+_username=vorot93
+_reponame=obozrenie
+pkgname=obozrenie-git
+pkgver=r252.a113ab8
pkgrel=1
pkgdesc='Simple and easy to use game server browser'
arch=('any')
-url='http://github.com/obozrenie'
+url='https://github.com/vorot93/obozrenie'
license=('GPL3')
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'gvfs' 'python-gobject'
- 'python-pytoml' 'python-xdg' 'gtk3' 'python-beautifulsoup4'
- 'python-xmltodict' 'qstat')
+depends=('desktop-file-utils' 'hicolor-icon-theme' 'gvfs' 'python-gobject' 'python-pytoml' 'python-xdg' 'gtk3' 'python-beautifulsoup4' 'python-xmltodict' 'qstat')
makedepends=('git' 'python-babel' 'python-setuptools')
-optdepends=('python-pygeoip: for geolocation support'
- 'geoip-database: for geolocation support')
-provides=('obozrenie')
-conflicts=('obozrenie')
+optdepends=('python-pygeoip: for geolocation support' 'geoip-database: for geolocation support')
install='obozrenie.install'
-source=('git+https://github.com/obozrenie/obozrenie.git')
+source=("git+https://github.com/$_username/$_reponame.git")
sha512sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd $_reponame
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd $_pkgname
+ cd $_reponame
python setup.py install --root="${pkgdir}" --optimize='1'
python setup.py compile_catalog -D io.obozrenie -d locale