summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c26fe6d28898..4aa35f0ab780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,23 @@
pkgname=obs-gphoto
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Allows connect DSLR cameras with obs-studio through gPhoto on Linux"
arch=("i686" "x86_64" "aarch64")
url="https://github.com/maaleske/obs-gphoto"
license=("GPL2")
-depends=("obs-studio" "libgphoto2")
+depends=("obs-studio>=28" "libgphoto2")
makedepends=("cmake" "git" "libcaption")
source=("$pkgname-$pkgver.tar.gz::https://github.com/maaleske/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=("6f1303582ea89f2f3203f86620ff5aeba66b5c83a8924c69e648845ae9fe2ba7")
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ sed -i 's/LibObs/libobs/' CMakeLists.txt
+ sed -i 's/${LIBOBS_LIBRARIES}/OBS::libobs/' CMakeLists.txt
+}
+
build() {
cd "$pkgname-$pkgver"