summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74965e0c051f..eac201f773f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-move-transition
-pkgver=2.9.1
+pkgver=2.9.4
pkgrel=1
pkgdesc="Plugin for OBS Studio to move sources to a new position during scene transition"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/move-transition.913/"
license=("GPL2")
-depends=("obs-studio>=28")
+depends=("obs-studio>=28" "glibc")
makedepends=("cmake" "git")
source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=702c67c06001d0042ae72241136f87badcb732b0")
sha256sums=("SKIP")
build() {
- cd "$pkgname"
- cmake -B build \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ cmake -B build -S $pkgname \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DLINUX_PORTABLE=OFF
+ -DLINUX_PORTABLE=OFF \
+ -Wno-dev
- make -C build
+ cmake --build build
}
package() {
- cd "$pkgname"
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
}