summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8983892d181
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
+pkgname=obs-source-record
+pkgver=0.1.4
+_obsver=26.1.2
+pkgrel=1
+pkgdesc="Plugin for OBS Studio to add a filter that allows you to record a source"
+arch=('x86_64')
+url="https://github.com/exeldro/obs-source-record"
+license=("GPL2")
+depends=("obs-studio")
+# Need to compile plugin in OBS compilation process
+makedepends=(
+ 'cmake' 'libfdk-aac' 'libxcomposite' 'x264' 'vlc' 'swig' 'python'
+ 'luajit' 'ffmpeg' 'jansson' 'libxinerama' 'libxkbcommon-x11' 'mbedtls'
+ 'qt5-svg' 'qt5-x11extras' 'curl' 'jack' 'gtk-update-icon-cache' 'git'
+)
+source=(
+ "$pkgname-$pkgver::git+https://github.com/exeldro/obs-source-record#commit=2e585b75484c46f41319320ac20125a82cf4fb0a"
+ "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
+ "fix_python_binary_loading.patch"
+)
+sha256sums=(
+ 'SKIP'
+ 'bc8b4c61ba4aae87b70c589a6a5b8538e4f03121b31e9b98a2071d9f6006b897'
+ 'bdfbd062f080bc925588aec1989bb1df34bf779cc2fc08ac27236679cf612abd'
+)
+
+prepare() {
+ rm -rf fakeroot
+ cd "obs-studio-$_obsver"
+ patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
+ cd plugins
+ cp -r "$srcdir/$pkgname-$pkgver" .
+ echo "add_subdirectory($pkgname-$pkgver)" | tee -a CMakeLists.txt >/dev/null
+}
+
+# Need to compile plugin in OBS compilation process
+build() {
+ cd "obs-studio-$_obsver"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DBUILD_CAPTIONS=ON
+ make -C build
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib/obs-plugins
+ mkdir -p "$pkgdir"/usr/share/obs/obs-plugins
+
+ cd "obs-studio-$_obsver"
+ make -C build DESTDIR="$srcdir/fakeroot/" install
+ cp -a "$srcdir"/fakeroot/usr/lib/obs-plugins/source-record.so "$pkgdir"/usr/lib/obs-plugins/
+ cp -a "$srcdir"/fakeroot/usr/share/obs/obs-plugins/source-record "$pkgdir"/usr/share/obs/obs-plugins/
+}