summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eb2cedc19bd..4a678e887050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-browser
-pkgver=27.1.3
-pkgrel=2
+pkgver=27.2.0
+pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming. Built with browser, vst plugins."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -15,7 +15,7 @@ depends=("ffmpeg" "jack" "jansson" "libxinerama" "libxkbcommon-x11"
"qt5-svg" "qt5-x11extras" "curl" "gtk-update-icon-cache" "mbedtls"
"pipewire" "libxcomposite")
makedepends=("cmake" "git" "libfdk-aac" "x264"
- "vlc-luajit" "swig" "luajit" "python" "cef-minimal>=91.0.0" "cef-minimal<95.0.0"
+ "vlc-luajit" "swig" "luajit" "python" "cef-minimal-obs"
"wayland" "qt5-wayland" "sndio")
optdepends=("libfdk-aac: FDK AAC codec support"
"libva-intel-driver: Hardware encoding"
@@ -32,14 +32,12 @@ source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git"
"git+https://github.com/obsproject/obs-vst.git"
- "fix_python_binary_loading.patch"
- "cef91.patch")
+ "fix_python_binary_loading.patch")
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177'
- 'b9e590190558648b34c0918f3e763c226aebfba543b547f0c7897dcaa2af23a9bc11493b6bc50dd23619b3992338e75ab4bed29e7b6e02f7e462ffbfb4905c38')
+ '93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177')
prepare() {
cd "$srcdir/$pkgname"
@@ -48,7 +46,6 @@ prepare() {
git config submodule.plugins/obs-browser.url "$srcdir"/obs-browser
git config submodule.plugins/obs-vst.url "$srcdir"/obs-vst
git submodule update
- patch -d "$srcdir/$pkgname/plugins/obs-browser" -Np1 < "$srcdir"/cef91.patch
}
build() {
@@ -60,7 +57,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_BROWSER=ON \
- -DCEF_ROOT_DIR="/opt/cef" \
+ -DCEF_ROOT_DIR="/opt/cef-obs" \
-DOBS_VERSION_OVERRIDE=$pkgver ..
make