summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f73e2425dc21..2a82ccffd211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,29 +12,35 @@ fi
_pluginname=tuna
pkgname=obs-$_pluginname
pkgver=1.6.1
-pkgrel=2
+pkgrel=3
arch=("i686" "x86_64" "aarch64")
pkgdesc="Get song info from right within obs"
url="https://obsproject.com/forum/resources/tuna.843/"
license=('GPL2')
-depends=("obs-studio")
-makedepends=("cmake" "git")
+depends=("obs-studio" "libmpdclient" "taglib")
+makedepends=("cmake" "vlc" "git")
conflicts=("obs-plugin-tuna-bin" "obs-plugin-tuna-git")
source=(
"$_pluginname::git+https://github.com/univrsal/tuna.git#tag=v$pkgver"
- "taglib::git+https://github.com/taglib/taglib"
- "libmpdclient::git+https://github.com/MusicPlayerDaemon/libmpdclient")
+ "FindLibMPDClient.cmake"
+ "FindTaglib.cmake"
+ "deps_CMakeLists.txt")
sha256sums=(
"SKIP"
- "SKIP"
- "SKIP"
+ "7a98baa9bcaddbb76cf00d11b3765fec4a696d2d793ef25c04939941e44cf4dc"
+ "8b6b5627dee73246eff61de3189d7ed33fe6c81c19373851feafe98421ffb3ae"
+ "6b90db87873aa90d1127200e0a23a7eb0a3bebad1c110fb698a1e421a06c6758"
)
prepare() {
cd $_pluginname
- git config submodule.deps/taglib.url $srcdir/taglib
- git config submodule.deps/libmpdclient.url $srcdir/libmpdclient
- git submodule update
+
+ cp $srcdir/FindLibMPDClient.cmake cmake/external/.
+ cp $srcdir/FindTaglib.cmake cmake/external/.
+ cp $srcdir/deps_CMakeLists.txt deps/CMakeLists.txt
+
+ sed -i '29 a find_package(LibMPDClient REQUIRED)\nfind_package(Taglib REQUIRED)\nfind_package(LibVLC REQUIRED)' CMakeLists.txt
+ sed -i '40 a include_directories(${LIBVLC_INCLUDE_DIRS})' CMakeLists.txt
}
build() {