summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 078876f0df38..8afcbb901054 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ depends=('obs-studio-git' 'qt5-websockets')
makedepends=('git' 'cmake')
provides=('obs-websocket')
conflicts=('obs-websocket')
-source=('git+https://github.com/jp9000/obs-studio.git' 'git+https://github.com/Palakis/obs-websocket.git')
-md5sums=('SKIP' 'SKIP')
+source=('git+https://github.com/jp9000/obs-studio.git' 'git+https://github.com/Palakis/obs-websocket.git' 'git+https://github.com/ARMmbed/mbedtls')
+md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/obs-websocket"
@@ -19,6 +19,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare(){
+cd "$srcdir/obs-websocket"
+git submodule init
+git config submodule."deps/mbedtls".url $srcdir/mbedtls
+git submodule update
+}
+
build() {
cd "$srcdir/obs-websocket"
mkdir build || true