summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b46e0e9d04de..8a039bef3be1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="obs-xdg-portal"
pkgname="${_pkgname}-git"
pkgver=0.1.2.r0.gfc5876a
-pkgrel=1
+pkgrel=2
pkgdesc="OBS Studio plugin using the Desktop portal for Wayland & X11 screencasting"
arch=(x86_64)
url="https://gitlab.gnome.org/feaneron/$_pkgname"
@@ -12,14 +12,22 @@ depends=('obs-studio' 'gst-plugins-base-libs' 'xdg-desktop-portal')
makedepends=('meson' 'git')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=("git+$url")
-md5sums=('SKIP')
+source=("git+$url"
+ 'fix-timestamp.patch')
+sha256sums=('SKIP'
+ 'e7fd7d3455a4b73cf750328d47ea3667d576106207a784ab2ce62c99eeb48813')
pkgver() {
cd "$_pkgname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ # https://gitlab.gnome.org/feaneron/obs-xdg-portal/-/merge_requests/4
+ git apply "$srcdir/fix-timestamp.patch"
+}
+
build() {
arch-meson "${_pkgname}" build
meson compile -C build