summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e0b75722b9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-bin_prot
+pkgver=112.35.00
+pkgrel=1
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="A binary protocol generator"
+url="https://github.com/janestreet/bin_prot"
+depends=('ocaml' 'camlp4' 'ocaml-type_conv')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz")
+options=('!strip')
+md5sums=('c6f5f10c475d80eac8b0f3d39b33c6ab')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "$OCAMLFIND_DESTDIR/stublibs"
+ DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" \
+ make install
+}