summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c1c42968cbc..08bf41e9b92c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-bin_prot
-pkgver=113.00.00
+pkgver=113.24.00
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="A binary protocol generator"
url="https://github.com/janestreet/bin_prot"
depends=('ocaml' 'camlp4' 'ocaml-type_conv')
-makedepends=('ocaml-findlib')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz")
+makedepends=('ocaml-findlib' 'opam')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
+ "libdir.patch")
options=('!strip')
-md5sums=('941c9e86e409b74eeeea771a78961157')
+md5sums=('135255aca999c2eb460ea578f7a93f11'
+ '7f0a951f1ac87385272ea7a6dd58762a')
+
+prepare() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ patch -Np1 < "${srcdir}/libdir.patch"
+}
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
@@ -23,9 +31,5 @@ build() {
package() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
- OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "$OCAMLFIND_DESTDIR/stublibs"
- DESTDIR="${pkgdir}" \
- OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" \
- make install
+ make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
}