summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 160a8e7cd322..fcfe1823a812 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=biniou
pkgname=ocaml-${_pkgname}
pkgver=1.2.2
-pkgrel=6
+pkgrel=7
pkgdesc="An optimized parsing and printing library for JSON"
arch=('x86_64')
url="https://github.com/ocaml-community/${_pkgname}"
license=('BSD')
options=('!strip' 'staticlibs')
provides=('ocaml-biniou')
-depends=('ocaml' 'ocaml-easy-format' 'ocaml-findlib' 'camlp-streams')
+depends=('ocaml' 'ocaml-easy-format' 'camlp-streams')
makedepends=('dune')
source=("${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz")
sha256sums=('8bf3ff17cd0ecb2d6b6d1d94cb08ef089d44caef96e9bae6be6839d428fa318f')
@@ -28,7 +28,7 @@ check() {
package() {
cd ${_pkgname}-${pkgver}
- DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlfind printconf destdir)"
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlc -where)"
install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
rm -r "${pkgdir}"/usr/doc
}