summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e062804b0c52..6161f2806afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=ocaml-biniou
_oname=biniou
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A binary data serialization format inspired by JSON'
arch=('i686' 'x86_64' 'armv7h')
options=('!strip' '!makeflags' 'staticlibs')
license=('BSD')
depends=('glibc')
-makedepends=('ocaml-easy-format' 'ocaml-findlib' 'ocamlbuild')
+makedepends=('ocaml-easy-format' 'ocaml-findlib' 'jbuilder')
url="https://github.com/mjambon/biniou"
source=("https://github.com/mjambon/${_oname}/archive/v${pkgver}.tar.gz")
sha256sums=('d939a9d58660201738c3d22ad5b7976deb2917b22591a07525807bb741357d36')
@@ -20,6 +20,9 @@ build() {
package() {
cd ${srcdir}/${_oname}-${pkgver}
+ export OPAMROOT="${srcdir}/.opam"
+ opam init -n
+ mkdir -p "${pkgdir}/usr/bin"
export OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
install -dm755 "$OCAMLFIND_DESTDIR"
jbuilder install