summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 32 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60a9bcedb1cd..a806234112e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,43 @@
-# Maintainer: oliver < a t > first . in-berlin . de
-pkgname=ocaml-camlzip
+# Maintainer: Marek Kubica <marek@xivilization.net>
+# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
+# Contributor: Sergei Lebedev <superbobry@gmail.com>
+# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Contributor: Sylvester Johansson <scj(at)archlinux(dot)us>
_pkgname=camlzip
-pkgver=1.06
-pkgrel=3
-pkgdesc="Provides easy access to compressed files in ZIP, GZIP and JAR format"
+pkgname=ocaml-$_pkgname
+_pkgver=rel110
+pkgver=1.10
+pkgrel=1
+pkgdesc="ZIP and gzip library for OCaml"
arch=('i686' 'x86_64')
-license=('custom: LGPL-2.1+ with OCaml linking exception')
-source=(http://forge.ocamlcore.org/frs/download.php/1616/camlzip-1.06.tar.gz)
-md5sums=(0874be16d02a7165dfc31edc06636e4c)
-url="http://forge.ocamlcore.org/projects/camlzip/"
-depends=('ocaml')
-makedepends=('ocaml' 'ocaml-findlib')
-# options=(!makeflags)
+url="https://github.com/xavierleroy/camlzip"
+license=('GPL')
+depends=('ocaml' 'zlib')
+makedepends=('ocaml-findlib')
+provides=('ocaml-zip')
+conflicts=('ocaml-zip')
+replaces=('ocaml-zip')
+options=(!strip staticlibs)
+source=("https://github.com/xavierleroy/$_pkgname/archive/$_pkgver.tar.gz")
+md5sums=('97efd563735b4b6e7ae463b91aa72405')
build() {
- cd ${srcdir}/${_pkgname}-${pkgver}
+ cd "$srcdir/$_pkgname-$_pkgver"
- make all
- make allopt
+ make all allopt
+ mkdir -p html
+ ocamldoc -html -d html gzip.mli zip.mli
}
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
+ cd "$srcdir/$_pkgname-$_pkgver"
- INSTALLDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "$INSTALLDIR"
- chmod 755 "$INSTALLDIR"
-
- env DESTDIR=${pkgdir} \
- OCAMLFIND_DESTDIR=${pkgdir}$(ocamlfind printconf destdir) \
- OCAMLFIND_LDCONF=ignore \
- ocamlfind install zip META *.mli *.a *.cmi *.cma *.cmxa *.so
+ export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
+ export OCAMLFIND_LDCONF="ignore"
+ mkdir -p "$OCAMLFIND_DESTDIR/stublibs"
+ make install-findlib
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -d -m 0755 "${pkgdir}/usr/share/doc/$pkgname"
+ install -t "${pkgdir}/usr/share/doc/$pkgname/" html/*
}