summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 15 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5f65957f097..808a57a1238d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,32 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-core
-pkgver=113.33.03
+pkgver=0.11.1
pkgrel=1
+epoch=1
pkgdesc="Industrial strength alternative to OCaml's standard library"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/core"
license=('Apache')
-depends=('ocaml' 'ocaml-bin_prot' 'ocaml-core_kernel' 'ocaml-fieldslib' 'ocaml-ppx_assert' 'ocaml-ppx_bench' 'ocaml-ppx_driver' 'ocaml-ppx_expect' 'ocaml-ppx_inline_test' 'ocaml-ppx_jane' 'ocaml-sexplib' 'ocaml-typerep' 'ocaml-variantslib')
-optdepends=('ocaml-utop: for coretop support')
-makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
+depends=('ocaml' 'ocaml-base' 'ocaml-configurator' 'ocaml-core_kernel' 'ocaml-ppx_assert' 'ocaml-ppx_jane' 'ocaml-sexplib' 'ocaml-spawn' 'ocaml-stdio' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+optdepends=('ocaml-utop: for coretop support'
+ 'ocamlbuild: for corebuild support')
+makedepends=('dune')
options=('!strip')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz"
- "libdir.patch")
-md5sums=('3a8c63205917a85de8ed597c11c1fc76'
- '7f0a951f1ac87385272ea7a6dd58762a')
-
-prepare() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
- patch -Np1 < "${srcdir}/libdir.patch"
-}
+source=("https://github.com/janestreet/core/releases/download/v${pkgver}/core-v${pkgver}.tbz")
+md5sums=('93ee333a0027bcda7cca3b323171d13b')
build() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/core-v${pkgver}"
- ./configure --prefix /usr
- make
+ jbuilder build
}
package() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/core-v${pkgver}"
- make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
+ install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/lib/ocaml/stubslibs" "${pkgdir}/usr/lib/ocaml/stublibs" # bug in opam
}