summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a52aec2c173..e80fe82cdafe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-fdkaac
-pkgver=0.3.2
-pkgrel=3
+pkgver=0.3.3
+pkgrel=1
pkgdesc="OCaml bingind for the fdk-aac library"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-fdkaac"
@@ -12,7 +12,7 @@ license=('GPL')
depends=('ocaml' 'libfdk-aac')
makedepends=('ocaml-findlib' 'dune')
options=('!strip')
-source=("https://github.com/savonet/ocaml-fdkaac/archive/${pkgver}.tar.gz")
+source=("https://github.com/savonet/ocaml-fdkaac/archive/refs/tags/v${pkgver}.tar.gz")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -23,10 +23,11 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+ dune install --prefix "${pkgdir}/usr" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
install -dm755 "${pkgdir}/usr/share/"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
-sha256sums=('0de28749e1435839ead013c385c6b963b88b57770e362e067139c2fd67a52e5f') \ No newline at end of file
+sha256sums=('c660008a9c4fc397963ee8c135b6b1b666b700ce1193ba77986b3c97c71fb404')