summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ff632ab2738..3a52aec2c173 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=ocaml-fdkaac
pkgver=0.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="OCaml bingind for the fdk-aac library"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-fdkaac"
license=('GPL')
depends=('ocaml' 'libfdk-aac')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip')
source=("https://github.com/savonet/ocaml-fdkaac/archive/${pkgver}.tar.gz")
@@ -23,8 +23,10 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- dune install --prefix "${pkgdir}/usr" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
sha256sums=('0de28749e1435839ead013c385c6b963b88b57770e362e067139c2fd67a52e5f') \ No newline at end of file