summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7125bdc27ede..db119fe7516e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=ocaml-gavl
pkgver=0.1.6
-pkgrel=1
+pkgrel=2
+_commit=df62b5969c4b12e3d1d2c2cbb1a5f45a70353f7c
pkgdesc="OCaml bindings for the Gavl video manipulation library"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-gavl"
@@ -10,20 +11,21 @@ license=('GPL2')
depends=('ocaml' 'gavl')
makedepends=('ocaml-findlib')
options=('!strip')
-source=("https://github.com/savonet/ocaml-gavl/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('6a95cb233b1929bd9d54431a7c7c4aa1')
+source=("https://github.com/savonet/${pkgname}/archive/${_commit}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure
- make
+ cd "${srcdir}/${pkgname}-${_commit}"
+ ./bootstrap
+ ./configure
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ cd "${srcdir}/${pkgname}-${_commit}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
}
+
+sha256sums=('2decc4402a0e08455d96ad9edd3bd729d62a5cc40e3468143ce48e471850256e')