summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 24 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bafc8d93b731..6cfdc11edf37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,46 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
# Contributor: Florian Dejonckheere <florian@floriandejonckheere.be>
# Contributor: Bartłomiej Piotrowski <spam@bpiotrowski.pl>
# Contributor: Nikolay Amiantov <nikoamia@gmail.com>
pkgname=ocaml-lablgl
-pkgver=1.05
-pkgrel=4
+pkgver=1.06
+pkgrel=12
pkgdesc='OCaml interface to OpenGL'
-url="https://forge.ocamlcore.org/projects/lablgl/"
-arch=('i686' 'x86_64')
+url="https://github.com/garrigue/lablgl"
+arch=('x86_64')
license=('BSD')
-depends=('glu' 'glut' 'libxi' 'libxmu' 'libgl' 'ocaml>=4.02')
-makedepends=('camlp4')
+depends=('glu' 'glut' 'libxi' 'libxmu' 'libgl' 'ocaml>=4.14.0')
options=('!strip' '!makeflags' 'staticlibs')
-source=("https://forge.ocamlcore.org/frs/download.php/1254/lablgl-$pkgver.tar.gz")
-sha256sums=('d8ff03e35b970d2b23a942f9e6ed65da5a6c123986bd0ecf5424a6205af34b61')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('d11852cbdbd40a14a22b30a218d009033c810de461e5717582f5dbe480296a7a')
prepare() {
- cd "lablgl-$pkgver"
- sed 17d Makefile.config.linux.mdk > Makefile.config
+ cd "${srcdir}"/lablgl-${pkgver}
+
+ printf 'RANLIB = :\n' > Makefile.config
+ printf 'GLLIBS = -lGL -lGLU\n' >> Makefile.config
+ printf 'GLUTLIBS = -lglut\n' >> Makefile.config
}
build() {
- cd "lablgl-$pkgver"
+ cd "${srcdir}"/lablgl-${pkgver}
+
make lib
make libopt
}
package() {
- cd "lablgl-$pkgver"
+ cd "${srcdir}"/lablgl-${pkgver}
- make install BINDIR="$pkgdir/usr/bin/" \
- LIBDIR="$pkgdir/usr/lib/ocaml/" \
- DDLDIR="$pkgdir/usr/lib/ocaml/stublibs/" \
- INSTALLDIR="$pkgdir/usr/lib/ocaml/lablGL/"
+ # Install routines are broken and don't ensure this is created first.
+ mkdir -p "${pkgdir}"/usr/lib/ocaml/stublibs
- install -Dm644 src/lablgl.cmxa "$pkgdir"/usr/lib/ocaml/lablgl.cmxa
- install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make install BINDIR="${pkgdir}/usr/bin/" \
+ LIBDIR="${pkgdir}/usr/lib/ocaml/" \
+ DDLDIR="${pkgdir}/usr/lib/ocaml/stublibs/" \
+ INSTALLDIR="${pkgdir}/usr/lib/ocaml/lablGL/"
- # Hack for wrongly placed stublibs library
- mv "$pkgdir/usr/lib/ocaml/stublibs" /tmp/temp.so
- mkdir -p "$pkgdir/usr/lib/ocaml/stublibs"
- mv /tmp/temp.so "$pkgdir/usr/lib/ocaml/stublibs/dlllablgl.so"
+ install -Dm644 src/lablgl.cmxa "${pkgdir}"/usr/lib/ocaml/lablgl.cmxa
+ install -Dm644 COPYRIGHT "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}