summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd7854a28d4f..bde16d902513 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: robertfoster
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ladspa
-pkgver=0.1.5
+pkgver=0.2.2
pkgrel=1
-license=('LGPL2.1')
+pkgdesc="OCaml bindings for LADSPA plugins"
arch=('i686' 'x86_64')
-pkgdesc=("OCaml bindings for LADSPA plugins")
url="https://github.com/savonet/ocaml-ladspa"
+license=('LGPL2.1')
depends=('ocaml')
-makedepends=('ocaml-findlib' 'ladspa')
-source=("https://github.com/savonet/ocaml-ladspa/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+makedepends=('dune' 'ladspa' 'ocaml-findlib')
options=('!strip')
-md5sums=('ae66337eb15dbbf0f432016e79db7267')
+source=("${url}/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
+
+sha256sums=('da089b3617a6219f69a7c5c4dbe87e6ad2cb1e290008f51c70d2ecfabc4c7e7a')