summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0df382e9448..e7ceccedb40e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,29 @@
# Contributor: Taylor Venable <taylor@metasyntax.net>
pkgname=ocaml-lambda-term
-pkgver=1.13
-pkgrel=3
+pkgver=2.0.2
+pkgrel=1
pkgdesc='A cross-platform library for manipulating the terminal'
arch=('i686' 'x86_64')
-url='https://github.com/diml/lambda-term'
+url="https://github.com/diml/lambda-term"
license=('BSD')
depends=('ocaml' 'ocaml-lwt' 'ocaml-lwt_log' 'ocaml-react' 'ocaml-zed' 'ocaml-camomile')
makedepends=('dune')
-source=("https://github.com/diml/lambda-term/releases/download/${pkgver}/lambda-term-${pkgver}.tbz")
options=('!strip')
-md5sums=('c13826a97014d4d573b927b623c7e043')
+source=("https://github.com/diml/lambda-term/releases/download/${pkgver}/lambda-term-${pkgver}.tbz")
+sha512sums=('61b4f3d80a8e17562cd7efe3a15258134a41fad67db200e9bde8896e39bff63c3274f3fff54f0233441555b5119fddcbea80fbab9b82caaa0b6b4deb56843f09')
build() {
cd "${srcdir}/lambda-term-${pkgver}"
- jbuilder build
+ dune build --profile release
}
package() {
cd "${srcdir}/lambda-term-${pkgver}"
- install -dm755 "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/man" "${pkgdir}/usr/share/"
+ dune install --destdir "${pkgdir}"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/man" "${pkgdir}/usr/share/"
}