summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a03e3f24c126..7577fb019d77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,28 +8,29 @@
pkgname=ocaml-menhir-compcert
_basepkgname=${pkgname%-*}
-pkgver=20200211
+pkgver=20210419
pkgrel=1
pkgdesc="Latest version of Menhir that can build the latest CompCert release."
arch=("i686" "x86_64")
url="http://cristal.inria.fr/~fpottier/menhir/"
-license=('GPL' 'QPL')
-depends=('ocaml>=4.02')
-makedepends=('ocamlbuild' 'ocaml-findlib' 'dune')
+license=('GPL' 'custom:QPL')
+depends=('ocaml>=4.02.3')
+makedepends=('dune>=2.0')
provides=($_basepkgname=$pkgver)
conflicts=($_basepkgname)
options=(!strip !makeflags)
source=("https://gitlab.inria.fr/fpottier/menhir/-/archive/$pkgver/menhir-$pkgver.tar.gz")
-sha256sums=('00f677401a92d91568a4faffb4977ab71a32a265de59e35419ad5b705d4a532d')
+sha256sums=('6b75a92276f1cdc8f1ea5030adad344a10bfce9077de274f621f5ef2c3428920')
build() {
cd "$srcdir/${_basepkgname/ocaml-/}-$pkgver"
-
dune build
}
package() {
cd "$srcdir/${_basepkgname/ocaml-/}-$pkgver"
dune install --prefix "${pkgdir}/usr" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ --libdir "lib/ocaml" \
+ --mandir "share/man"
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}