summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 637dbbf2e3f9..6c7b073daede 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_inline_test
-pkgver=0.11.0
-pkgrel=2
+pkgver=0.12.0
+pkgrel=1
epoch=1
pkgdesc="Syntax extension for writing in-line tests in ocaml code"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_inline_test"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip' '!emptydirs')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_inline_test-v${pkgver}.tar.gz")
-md5sums=('1f2e014332373638696d8893d87f4682')
+sha512sums=('136555310442e479b676167d44a6dffb6f56517359165fe64778e863fd58021524a2fcd1d1246cd705fab62e3e510c60afcb20a574ac43687c86b7bbd990936d')
build() {
cd "${srcdir}/ppx_inline_test-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_inline_test-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}