summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7dcb50ad9ab..53fd3ee5d084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
-pkgver='0.29.1'
-pkgrel='2'
-pkgdesc='Standard library for ppx rewriters'
+pkgver='0.30.0'
+pkgrel='1'
+pkgdesc='Standard infrastructure for ppx rewriters'
# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.08.0' 'ocaml-base>=0.15.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0>=0.15.0' 'ocaml-stdlib-shims' 'ocaml-yojson')
+depends=('ocaml>=4.04.1' 'ocaml-base>=0.15.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0>=0.15.0' 'ocaml-stdlib-shims' 'ocaml-yojson')
makedepends=('dune>=2.7.0')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('9bfd52709a63399ff35697b442de6818e2a61b9a2ccf33638f2da6295e3e034e2ae6108a2b8567402e80d928636cdee1572cc14d228a47fbda50625219e411f9')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('a7310c5c0fe76c72984bc6a27648bf12ac83222c029b91a7abf8be13f1950f84de4b24e28f2bb50a6a65c16c9a6bb8c4d3d0596c4b5f7f5bedba87f8ca55a810')
_sourcedirectory="$_projectname-$pkgver"
@@ -23,7 +23,7 @@ build() {
}
# fails because of a circular dependency on this package by ppx_jane
-# $pkgname-$pkgver-$pkgrel-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111
+# $pkgname-$pkgver-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111
# check() {
# cd "$srcdir/$_sourcedirectory/"
# dune runtest --release --verbose