summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 803414746038..77b825807cdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,20 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
-pkgver='0.22.2'
-pkgrel='2'
+pkgver='0.23.0'
+pkgrel='1'
pkgdesc='Standard library for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree2>=2.2.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
+depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0>=0.12.0' 'ocaml-stdlib-shims')
makedepends=('dune>=2.7.0')
options=('!strip')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
- 'ocaml-migrate-parsetree2.diff'
-)
-sha256sums=('8bdb42e3fb17240ad5578da621c37c73bbc02507ecc27d193d1b4cf11a4ea05d'
- '7c9586671c3b39e49b7f38c7c7765887cba1a9417484b3c1112677997da35d12')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('477ddd08a5a8ee1edca668cd3b6b4b116778b3d36d7a79b8eef748d356cdf58d')
_sourcedirectory="$_projectname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- patch --forward -p1 < '../ocaml-migrate-parsetree2.diff'
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose