summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 30 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc02f7fdd5f2..1a31ed24d491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,41 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-ppxlib
-pkgver=0.6.0
-pkgrel=1
-pkgdesc="Base library and tools for ppx rewriters"
-arch=('x86_64')
-url='https://github.com/ocaml-ppx/ppxlib'
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppxlib'
+pkgname="ocaml-$_projectname"
+pkgver='0.12.0'
+pkgrel='1'
+pkgdesc='Base library and tools for ppx rewriters'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml' 'ocaml-base' 'ocaml-compiler-libs-repackaged' 'ocaml-migrate-parsetree' 'ocaml-ppx_derivers' 'ocaml-stdio')
+depends=('ocaml>=4.04.1' 'ocaml-base>=0.11.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree>=1.3.1' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-stdio>=0.11.0')
makedepends=('dune')
+# checkdepends=('ocampl-cinaps>=0.12.1' 'ocaml-findlib')
options=('!strip')
-source=("https://github.com/ocaml-ppx/ppxlib/releases/download/${pkgver}/ppxlib-${pkgver}.tbz")
-sha512sums=('dcb92285a4822499f66d86947cfcae25bbdbfec0df7c861c08cdcfe7b958dcb0ad6b42ca7737436150d0eebbaccc62d742fb37fc81c66c81e1d88b127654a06c')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('6b562c9b3b9350777318729921f890850b385c469db60769aafd9371998a2c42')
-build() {
- cd "${srcdir}/ppxlib-${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- dune build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
}
+# re-enable when ocaml-ppx_jane (dep of ocampl-cinaps) is updated
+# check() {
+# cd "$srcdir/$_sourcedirectory/"
+# dune runtest -p "$_projectname" --verbose
+# }
package() {
- cd "${srcdir}/ppxlib-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
- install -Dm755 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}