summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c899d33af57d..5997b172ad3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,35 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
-pkgver='0.14.0'
+pkgver='0.15.0'
pkgrel='1'
-pkgdesc='Base library and tools for ppx rewriters'
+pkgdesc='Standard library for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.1' 'ocaml-base>=0.11.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree>=1.5.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-stdio>=0.11.0')
-makedepends=('dune')
+depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree>=1.5.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
+makedepends=('dune>=1.11.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('4b14134648f0452b9dbe64207c4f264c00f9c5634ad1cadfe0ea9f42dd85347f')
+sha256sums=('d3bfed08737130d663419354ae309fb4d383f4e0110d5b5e7808d93b078a584f')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
# fails because of a circular dependency on this package by ppx_jane
# $pkgname-$pkgver-$pkgrel-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111
# check() {
# cd "$srcdir/$_sourcedirectory/"
-# dune runtest -p "$_projectname" --verbose
+# dune runtest --release --verbose
# }
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"