summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 958d2afeab6b..7befb3afd497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yojson
pkgname=ocaml-${_pkgname}
-pkgver=1.7.0
+pkgver=2.1.2
pkgrel=1
pkgdesc="Low level JSON binary for OCaml"
arch=('x86_64')
@@ -12,22 +12,29 @@ license=('BSD')
options=('!strip' 'staticlibs')
provides=('ocaml-yojson')
conflicts=('ocaml-yojson')
-depends=('ocaml-biniou' 'ocaml-easy-format')
+depends=('ocaml' 'ocaml-biniou' 'ocaml-easy-format')
makedepends=('dune' 'cppo')
source=(https://github.com/ocaml-community/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz)
-sha256sums=('656fc65f794186274f8b961dc38daba9e2de2fc993829291defbda2186812cc6')
+sha256sums=('59f2f1abbfc8a7ccbdbf608894e5c75e8a76006e34899254446f83e200dfb4f9')
build() {
- cd ${_pkgname}-${pkgver}
- make all
+ cd ${_pkgname}-${pkgver}
+
+ # no benchmarks
+ rm -rf bench/
+
+ # we're using ocaml > 4.08
+ sed -i '/libraries seq/d' lib/dune
+
+ make all
}
package() {
- cd ${_pkgname}-${pkgver}
+ cd ${_pkgname}-${pkgver}
- DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="lib/ocaml"
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="/usr/lib/ocaml"
- # remove rogue dune-package file
- rm -r "${pkgdir}"/usr/doc
- rm -r "${pkgdir}"/usr/lib/ocaml/${_pkgname}/dune-package
+ # remove rogue dune-package file
+ rm -r "${pkgdir}"/usr/doc
+ rm -r "${pkgdir}"/usr/lib/ocaml/${_pkgname}/dune-package
}