summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9501472c6fb5..d6767f36cec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,29 @@
# Contributor: Taylor Venable <taylor@metasyntax.net>
pkgname=ocaml-zed
-pkgver=1.6
+pkgver=2.0.3
pkgrel=1
pkgdesc="An abstract engine for text editing"
arch=('i686' 'x86_64')
url='https://github.com/diml/zed'
license=('BSD')
-depends=('ocaml' 'ocaml-camomile' 'ocaml-react')
+depends=('ocaml' 'ocaml-camomile' 'ocaml-react' 'ocaml-charinfo_width')
makedepends=('dune')
options=('!strip')
source=("https://github.com/diml/zed/archive/${pkgver}.tar.gz")
-md5sums=('db050d98f4b7051530e023a5e2c4f438')
+sha512sums=('b1c790d2a0d0b6fe8d43a718716910ebb38c16a8adad553f08120dfb653da971312ce760d68efb458b662bc8c39c60c46b9c3e951f61535f7972b444f4eabdbc')
build() {
cd "${srcdir}/zed-${pkgver}"
- jbuilder build
+ dune build --profile release
}
package() {
cd "${srcdir}/zed-${pkgver}"
- mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ dune install --destdir "${pkgdir}"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}