summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45115b859583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=tsa
+pkgname=octave-$_pack
+pkgver=4.3.2
+pkgrel=1
+pkgdesc="Stochastic concepts and maximum entropy methods for time series analysis"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=2.9.7')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('8aaddde1714576c15872cb0997eefaa6')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave-cli -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}