summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f53662af8ae1..66c7bdb66a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Benjamin Chrétien <chretien dot b+arch at gmail dot com>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: Benjamin Chrétien <chretien dot b+arch at gmail dot com>
# Contributor: Soo-Hyun Yoo <yoos117@gmail.com>
+
pkgname=octomap
-pkgver=1.7.0
+pkgver=1.9.0
pkgrel=1
pkgdesc="A probabilistic, flexible, and compact 3D mapping library for robotic systems."
arch=('i686' 'x86_64')
url="http://octomap.github.com/"
-license=('New BSD License')
-groups=()
-depends=()
+license=('BSD')
+depends=('gcc-libs')
makedepends=('cmake')
provides=('octomap')
conflicts=('octomap-git')
-source=("https://github.com/OctoMap/octomap/archive/v${pkgver}.tar.gz")
-sha256sums=('c5f2f647465be92836697534dd4bb19a9185f541323e2fe09cfaa78cd1d9bf04')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/OctoMap/octomap/archive/v${pkgver}.tar.gz")
+sha256sums=('5f81c9a8cbc9526b2e725251cd3a829e5222a28201b394314002146d8b9214dd')
build() {
cd "$srcdir/octomap-$pkgver/octomap"