summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 21 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6a144c4001e..f3d58b811119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer: Javier Tia <javier.tia@gmail.com>
-pkgname=office-code-pro
-_srcname=Office-Code-Pro
-pkgver=1.004
-pkgrel=1
-depends=(fontconfig xorg-font-utils)
-pkgdesc="Office Code Pro is a customized version of Source Code Pro for text editors and coding environments"
-url="https://github.com/nathco/Office-Code-Pro"
-license=(custom)
-arch=(any)
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Javier Tia <javier.tia@gmail.com>
-source=("https://github.com/nathco/$_srcname/archive/$pkgver.tar.gz")
-sha256sums=('9bca923d17f6c47a586d8e4567d46ccfa58fb8b8e2247b5ee2a19da1597c58f6')
+# otfinfo --info *.otf
-install=$pkgname.install
+_pkgname='Office-Code-Pro'
+_commit='d8fe9b1655a449d5fa4952d8388a626bfd87d652'
+pkgname="${_pkgname,,}"
+pkgver=1.004+1
+pkgrel=1
+pkgdesc='Customized version of Source Code Pro font'
+arch=('any')
+url="https://github.com/phooky/${_pkgname}"
+license=('custom: SIL Open Font License 1.1')
+source=("${_pkgname}::git+${url}#commit=${_commit}")
+makedepends=(git)
+sha256sums=(SKIP)
package() {
- install -Dm644 $srcdir/$_srcname-$pkgver/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- install -d "$pkgdir/usr/share/fonts/OTF/"
- cd $srcdir/$_srcname-$pkgver/Fonts/Office\ Code\ Pro/OTF/
- install -t "$pkgdir/usr/share/fonts/OTF/" -m644 *.otf
-
- cd $srcdir/$_srcname-$pkgver/Fonts/Office\ Code\ Pro\ D/OTF/
- install -t "$pkgdir/usr/share/fonts/OTF/" -m644 *.otf
+ cd "${_pkgname}"
+ find 'Fonts' -type f -name "*.otf" -exec install -Dvm644 "{}" -t "${pkgdir}/usr/share/fonts/OTF" \;
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: