summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b1bc4284599
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Lothar_m <lothar_m at riseup dot net>
+
+_pkgname=ofxparse
+pkgname=$_pkgname-git
+pkgver=0
+pkgrel=3
+pkgdesc="Ofxparse is a parser for Open Financial Exchange (.ofx) format files."
+arch=('i686' 'x86_64')
+url="https://github.com/jseutter/ofxparse"
+license=('MIT')
+makedepends=('git')
+depends=('python2>=2.7.6'
+ 'python2-nose'
+ 'python2-coverage'
+ 'python2-beautifulsoup4')
+#optdepends=('')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($_pkgname::git://github.com/jseutter/ofxparse.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ python2 setup.py build
+}
+
+package() {
+ cd $_pkgname
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+