summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62903de1c8e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+pkgname=('ogre-git')
+pkgver=2.2.0.r8509.37e9fc7b8ae8
+pkgrel=1
+pkgdesc='Scene-oriented, flexible 3D engine written in C++'
+arch=('i686' 'x86_64')
+url='http://ogre3d.org'
+license=('MIT')
+depends=('boost-libs' 'freeimage' 'freetype2' 'libxaw' 'libxrandr'
+ 'nvidia-cg-toolkit' 'zziplib' 'ois' 'glu' 'tinyxml')
+makedepends=('boost' 'cmake' 'doxygen' 'graphviz' 'ttf-dejavu' 'mesa' 'mercurial')
+provides=('ogre' 'ogre-docs')
+_dir="OGRE"
+source=("hg+http://bitbucket.org/sinbad/ogre")
+sha512sums=('SKIP')
+
+prepare() {
+ cd ogre
+}
+
+pkgver() {
+ cd ogre
+ printf "2.2.0.r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd ogre
+
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
+
+ # Silence warnings about deprecated declarations
+ CXXFLAGS+=' -Wno-deprecated-declarations'
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DOGRE_INSTALL_SAMPLES=TRUE \
+ -DOGRE_INSTALL_DOCS=TRUE \
+ -DOGRE_INSTALL_SAMPLES_SOURCE=TRUE \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+
+ make OgreDoc
+}
+
+package() {
+ optdepends=('cppunit: unit testing'
+ 'intel-tbb: better threading support'
+ 'poco: portability'
+ 'boost: for developing using ogre')
+
+ cd ogre/build
+
+ make DESTDIR=${pkgdir} install
+
+ install -Dm644 ../Docs/License.html ${pkgdir}/usr/share/licenses/${pkgname}/license.html
+
+
+ # symlink for docs
+ install -dm755 ${pkgdir}/usr/share/OGRE/
+ cd ${pkgdir}/usr/share
+ ln -s /usr/share/doc/OGRE/ OGRE/docs
+
+}