summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5c1585c4153..93affff0054b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,8 @@ pkgdesc='An interactive Git learning game!'
arch=(x86_64)
url='https://ohmygit.org/'
license=(custom)
-makedepends=(godot3 godot3-export-templates zip)
+depends=(libglvnd libxcursor libxi libxinerama libxrandr libxrender)
+makedepends=(git godot3 godot3-export-templates xorg-server-xvfb zip)
source=("${pkgname}::git+https://github.com/git-learning-game/oh-my-git.git"
oh-my-git
oh-my-git.desktop
@@ -43,7 +44,7 @@ build() {
ln -sf --no-dereference /usr/share/godot/templates/"$godot_minor"* "$templates_dir/$godot_version"
done
# build game
- HOME="${srcdir}" make linux
+ HOME="${srcdir}" xvfb-run make linux
}
package() {