summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d927d182dad4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Allenyou <cfan789123@126.com>
+pkgname=oi-tools-allenyou
+pkgver=1.0.1000r
+pkgrel=1
+epoch=0
+pkgdesc="Tools for OIers by Allenyou."
+arch=(any)
+url="https://www.allenyou.wang"
+license=('GPL3')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://aurlib.allenyou.wang/$pkgname/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('e2660dbaa051985d27f0723095db23fd')
+validpgpkeys=()
+
+build() {
+ cd "$startdir"/src/"$pkgname-$pkgver"
+ # cd src/"$pkgname-$pkgver"
+ g++ ConsolePauser.cpp -o ConsolePauser
+ g++ pause.cpp -o pause
+}
+
+package() {
+ # cd "$pkgname-$pkgver"
+ # make DESTDIR="$pkgdir/" install
+ cd "$startdir"/src/"$pkgname-$pkgver"
+ install -D -m=775 ConsolePauser "${pkgdir}/usr/bin/ConsolePauser"
+ install -D -m=775 pause "${pkgdir}/usr/bin/pause"
+}