summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbe9fd3ee717..5191d81c9700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: León Bohn <leon.bohn@rwth-aachen.de>
pkgname=oink-git
-pkgver=r106.0beaf69
pkgrel=1
+pkgver=r108.0464439
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
pkgdesc="Oink is an implementation of modern parity game solvers written in C++."
arch=('i686' 'x86_64')
url="https://github.com/trolando/oink"
licecnse=('Apache 2.0')
-source=("oink-git::git+https://github.com/trolando/oink#commit=0beaf69")
+source=("oink-git::git+https://github.com/trolando/oink#commit=0464439")
makedepends=('git' 'gcc' 'make' 'cmake' 'boost')
depends=('boost-libs')
md5sums=('SKIP')
+
build() {
cd $pkgname
mkdir build && cd build