summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14c0825f578e..f99be056dd6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
# Maintainer: ValHue <vhuelamo at gmail dot com>
-# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: ValHue <vhuelamo at gmail dot com>
#
pkgname="ojo"
-pkgver="0.1.0.r134"
+pkgver="0.2.0.r228"
pkgrel="2"
-pkgdesc="A fast and good-looking image viewer"
+pkgdesc="A fast and good-looking image viewer, nice as a preliminary stage in a \
+ photography workflow"
+url="http://launchpad.net/~ojo/+archive/ubuntu/daily"
arch=('i686' 'x86_64')
-url="http://launchpad.net/~ojo"
license=('GPL3')
-depends=('hicolor-icon-theme' 'python2' 'pyexiv2')
-makedepends=('desktop-file-utils' 'python2-distutils-extra')
+depends=('hicolor-icon-theme' 'python' 'pyexiv2')
+makedepends=('desktop-file-utils' 'python-distutils-extra')
optdepends=()
conflicts=('ojo-bzr')
provides=('ojo')
-source=("https://launchpad.net/~ojo/+archive/ubuntu/daily/+files/ojo_0.1-0~134~201608081617~ubuntu16.10.1.tar.gz")
-sha256sums=('42ada6df33eaaefc6f1ccadda113c769ce68ba01766cc65f60fe7d2b6680f845')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/+files/ojo_0.2-0~228~201903042116~ubuntu19.04.1.tar.gz")
+sha256sums=('7e2f0d87ffbc9ec2d3714590f6d77e5169889f2a48ee8df353a095d7ae6b9fcf')
build() {
- cd "${pkgname}-0.1"
+ cd "${pkgname}-0.2"
python2 setup.py build
}
package() {
- cd "${pkgname}-0.1"
+ cd "${pkgname}-0.2"
python2 setup.py install --root="${pkgdir}"
rm -rf "${pkgdir}/usr/share/doc"
}
-# vim:set ts=4 sw=2 ft=sh et:
+# vim: set ts=4 sw=4 et syn=sh ft=sh: