summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46e36710bb87..35869977aac3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=okular
pkgname=okular-no-purpose
pkgver=21.04.3
-pkgrel=1
+pkgrel=2
pkgdesc='Okular, a document viewer, without the dependency on purpose. This disables the share menu'
arch=(x86_64)
url='https://apps.kde.org/okular/'
@@ -20,14 +20,20 @@ conflicts=(okular)
replaces=(kdegraphics-okular)
replaces=(okular)
provides=(okular)
-source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig})
+source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig}
+ https://invent.kde.org/graphics/okular/-/commit/504eec76.patch)
sha256sums=('fa1fc1a4a4d84c1e568665d4c05cd00f71c5ba481dad7b6b8d83597a428b5056'
- 'SKIP')
+ 'SKIP'
+ '2f42249257cfd3c2c79f2532a8c0e54f11c8aef88b5d5dcccf8ceea776ed3b75')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
options=(!zipman)
+prepare() {
+ patch -d $_pkgname-$pkgver -p1 < 504eec76.patch # Fix fictionbook plugin id
+}
+
build() {
cmake -B build -S $_pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \