summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 189697d47b63..5ba62f950bf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=ola-git
pkgver=0.9.5.r406.gaad3ac0
pkgrel=1
pkgdesc="The Open Lighting Architecture (OLA) provides a plugin framework for distributing DMX512 control signals on Mac and Linux"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="https://www.openlighting.org/ola/"
license=('LGPL2.1' 'GPL2')
provides=('ola')
@@ -12,18 +12,20 @@ makedepends=('git')
depends=('libmicrohttpd' 'cppunit' 'protobuf' 'python2-protobuf' 'python2')
optdepends=('liblo' 'avahi' 'libusb' 'libusb-compat' 'libftdi-compat' 'openslp')
conflicts=('ola')
-source=("${pkgname}"::'git+https://github.com/OpenLightingProject/ola.git')
+source=("git+https://github.com/OpenLightingProject/ola.git")
# uncomment for 0.9.5
#source=("$pkgname::git+https://github.com/OpenLightingProject/ola#tag=0.9.5")
sha256sums=('SKIP')
+_gitname="ola"
+
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${_gitname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${_gitname}"
autoreconf -i
# since protobuf isnt ported to python 3 we have to choose python 2
PYTHON=python2 ./configure --prefix=/usr --enable-python-libs --disable-unittests --disable-fatal-warnings
@@ -31,5 +33,5 @@ build() {
}
package() {
- make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" install
+ make -C "${srcdir}/${_gitname}" DESTDIR="${pkgdir}" install
}