summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3678630202e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Bleuzen <supgesu at gmail dot com>
+
+pkgname=olivia
+pkgver=r182.517136a
+pkgrel=1
+pkgdesc="Deadass music player for Linux"
+arch=('i686' 'x86_64')
+url="https://github.com/keshavbhatt/olivia"
+license=('GPL3')
+depends=('qt5-base' 'qt5-tools' 'mpv' 'python' 'wget')
+source=("git+https://github.com/keshavbhatt/olivia.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ qmake Olivia.pro -spec linux-g++ CONFIG+=release
+ make
+}
+
+package() {
+ # make install
+ cd "$pkgname"
+ mkdir -p "$pkgdir"/usr/bin/
+ install -m755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+}