summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 219394220762..b1e38224120b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=ollama-cuda
pkgdesc='Create, run and share large language models (LLMs) with CUDA'
-pkgver=0.1.12
-pkgrel=2
+pkgver=0.1.13
+pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
license=(MIT)
-_ollamacommit=16a900630616f47ea18026150cad82d5e8008c01 # tag: v0.1.12
+_ollamacommit=cedae0d17a38a23269191bf69f2b2248aa830303 # tag: v0.1.13
# The git submodule commit hashes are here:
-# https://github.com/jmorganca/ollama/tree/v0.1.12/llm/llama.cpp
+# https://github.com/jmorganca/ollama/tree/v0.1.13/llm/llama.cpp
_ggmlcommit=9e232f0234073358e7031c1b8d7aa45020469a3b
_ggufcommit=9656026b53236ed7328458269c4c798dd50ac8d1
makedepends=(cmake cuda git go setconf)
@@ -53,10 +53,12 @@ build() {
go build -buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-linkmode=external -ldflags=-buildid=''
}
-check() {
- cd ${pkgname/-cuda}
- go test ./...
-}
+# "go test" is disabled temporarily because it stopped working,
+# see also: https://github.com/jmorganca/ollama/pull/709#issuecomment-1845583194
+#check() {
+# cd $pkgname
+# go test ./...
+#}
package() {
install -Dm755 ${pkgname/-cuda}/${pkgname/-cuda} "$pkgdir/usr/bin/${pkgname/-cuda}"