summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7098b67e8d24..700bbc074ddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=omp
pkgver=0.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Open-Source Music Player'
url='https://openmusicplayer.com/'
arch=(x86_64)
@@ -18,7 +18,13 @@ sha256sums=('SKIP')
build() {
cd "OMP-$pkgver"
- make -e FLATPAK=1
+
+ CXXFLAGS='-g -DFLATPAK=$(FLATPAK) -std=c++17 -Wall -pipe'
+ CXXFLAGS+=' -Wno-deprecated-declarations '
+ CXXFLAGS+=' -Wno-parentheses -fconcepts -Wno-catch-value -Wno-return-type'
+
+ make -e FLATPAK=0 CXXFLAGS=$(CXXFLAGS)
+
}
package() {